CentOS 7 安装 Nodejs npm 及版本冲突解决

sudo npm install –unsafe-perm

JC&BC 笔记:

可能没安装过 npm 的人会有点疑惑,安装 npm 跟安装 nodejs 有什么关系?

安装 npm 其实就是安装 nodejs 的过程。这一点官方说的很明白,npm 依赖于 nodejs 环境中

安装完 nodejs ,npm 也就安装好了。下面具体说一下安装的过程:

1. 首先找到 npm 官网 :https://docs.npmjs.com/getting-started/installing-node

这里面有安装的教程,分两种安装:repo 安装 和 手动编译,这里使用简单且不易出错的第一种安装方式。

2. 首先安装 nodsjs 然后再更新 npm

3.安装 nodejs  [官方介绍请看这里:https://github.com/nodesource/distributions]

【安装及卸载的过程都需要在 root 权限下操作,下面的命令也都是在 root 权限下操作的,官方已明确说明】

我安装了两次,第一次安装的是 Node.js  v9.x 由于版本过高,导致后面更新的最新版本的 npm 无法与node环境配套,最终无法使用。

所以把原来安装的 npm 及node环境全部卸载后重新安装。

 

【卸载npm:sudo npm uninstall npm -g   ,

卸载nodejs包:yum remove nodejs,

cd 到yum源配置文件夹:cd /etc/yum.repo.d ,删除以 node 开头的源;

清除 yum 缓存 yum clean all 】

 

然后重新安装了 Node.js v6.x 版本,之后更新 npm 为最新版本的 v5.5.1 (nodejs 与 npm 版本的对应都是一个范围值,不是必须由哪个版本才能配套哪个版本)

版本对应关系可参考:http://nodejs.org/dist/npm-versions.txt ,不过这个文件在我安装的时候就已经老掉牙了,版本更新对应关系没跟上没什么太大参考价值。

安装命令:【自己也可以参考官方的: https://github.com/nodesource/distributions#rpminstall】

 

1. 安装 nodejs:

curl -sL https://rpm.nodesource.com/setup_6.x  |  bash  –

yum install -y nodejs

如果提示你需要安装构建工具 gcc gcc++ 什么的你就安装就行了,安装完了再重新安装 nodejs

命令:node -v 如果输出版本号就安装成功了。

 

2.  更新 npm (此时的 npm 命令已经随 nodejs 的安装过程给安装了,这里可能只是为了更新一下我也不太明白)

npm install npm@latest -g

命令:npm -v 输出版本号就成功安装了。

==============================================

https://nodejs.org/en/

选择下载后上传或直接使用wget下载

wget https://nodejs.org/dist/v8.11.2/node-v8.11.2-linux-x64.tar.xz

2.解压

***.tar.xz格式文件需要两部解压步骤

1>xz -d node-v8.11.2-linux-x64.tar.xz

2>tar -xvf node-v8.11.2-linux-x64.tar

3.配置环境目录

ln -s /usr/local/node/node-v8.11.2-linux-x64/bin/node /usr/local/bin/node

ln -s /usr/local/node/node-v8.11.2-linux-x64/bin/npm /usr/local/bin/npm

其中/usr/local/node为node安装目录

4.验证

node -v

输出版本号v8.11.2即说明已完成

二.卸载

1.自带工具删除

yum remove nodejs npm -y

2.手动删除残留

进入 /usr/local/lib 删除所有 node 和 node_modules文件夹

进入 /usr/local/include 删除所有 node 和  node_modules 文件夹

进入 /usr/local/bin 删除 node 的可执行文件node和npm

检查 ~ 文件夹里面的”local”   “lib”  “include”  文件夹,然后删除里面的所有  “node” 和  “node_modules” 文件夹

完成。

 

Leave a Comment

电子邮件地址不会被公开。 必填项已用*标注